Permalink
Browse files

README: added gstreamer1.0-gtk3 to dependencies

The gtksink seems to have moved from -bad to -good and Debian builds it
in a separate package:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=894483.
  • Loading branch information...
muelli committed Jun 26, 2018
1 parent 12ec642 commit 5c3711f8f03787bcc1267bbd116319971d411e18
Showing with 5 additions and 2 deletions.
  1. +5 −2 README.rst
@@ -69,10 +69,13 @@ so it should be easy for you to install it.
If your version is older than that,
this list of packages seems to make it work:
python python-lxml avahi-daemon python-avahi python-gi gir1.2-glib-2.0 gir1.2-gtk-3.0 python-dbus gir1.2-gstreamer-1.0 gir1.2-gst-plugins-base-1.0 gstreamer1.0-plugins-bad gstreamer1.0-plugins-good python-gi-cairo python-gpg python-twisted
python python-lxml avahi-daemon python-avahi python-gi gir1.2-glib-2.0 gir1.2-gtk-3.0 python-dbus gir1.2-gstreamer-1.0 gir1.2-gst-plugins-base-1.0 gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gstreamer1.0-gtk3 python-gi-cairo python-gpg python-twisted
In Ubuntu, the package
gstreamer1.0-plugins-bad provides the zbar and the gtksink element, and
gstreamer1.0-plugins-bad provides the zbar element and in versions older
than 18.04 the gtksink element.
In newer versions of Ubuntu, the gtksink elment is provided by the
gstreamer1.0-gtk3 packages.
gstreamer1.0-plugins-good provides the autovideosrc element.
These packages should be optional:

0 comments on commit 5c3711f

Please sign in to comment.