RuboCop configuration which has the same code style checking as official Ruby on Rails
Ruby
Clone or download
Latest commit 763e79a May 23, 2018

README.md

RuboCop Rails

Build Status Gem Version

RuboCop configuration which has the same code style checking as official Ruby on Rails.

Official RoR Rubocop Configuration

Installation

Add this line to your application's Gemfile:

gem "rubocop-rails"

Usage

Add this line to your application's .rubocop.yml, or just run rails generate rubocop_rails:install:

inherit_gem:
  rubocop-rails:
    - config/rails.yml

Customization

If you'd like to customize the rubocop setting, you can override it.

For example, if you want to change TargetRubyVersion, you can do it like:

inherit_gem:
  rubocop-rails:
    - config/rails.yml

AllCops:
  TargetRubyVersion: 2.3

This overrides config/rails.yml setting with TargetRubyVersion: 2.3.

License

The gem is available as open source under the terms of the MIT License.